Common questions and answers

I see a black screen when switching in/out of Apple CarPlay/Android Auto

This is a simple setting issue.

In the interface SETUP menu, please ensure all the following menu options are set to OFF. If one channel was left ON the black screen will appear.
• FRONTVIEW
• REARVIEW
• DVR
• DVD
• TV
• BT

I don’t hear sound from Apple CarPlay/Android Auto

This could be caused by an incorrect setting or incorrect audio connection.

Setting – Ensure that your original car stereo unit is switched to AUX input before entering CarPlay/Android Auto. All sound from Apple CarPlay/Android Auto is via the AUX channel.

Wiring connection – please check the manual and ensure the audio cable is connected correctly.

I don’t have display

This could be caused by incorrect DIP switch settings or incorrect wiring connection.

There are 8 dip switches at the rear of IDCORE interface box. Please check the manual and make sure they are set correctly to your car model.

Please double check the LCD cable connections against your installation manual.

My NAV button doesn’t switch between IDCORE menu and factory menu (applicable to Audi with MMI models only)


This could be caused by incorrect DIP switch settings or incorrect wiring connection.

There are 8 dip switches at the rear of IDCORE interface box. Please check the manual and make sure they are set correctly to your car model.

The blue/white loose wire labelled ‘MMI’ from the CarPlay power wiring is to enable central MMI button control. If this wire is not connected securely or not connected to the correct wire, your central MMI buttons including Nav button will not switch in/out and control Apple CarPlay/Android Auto.

Please check this against manual as to which wire to connect.

How to stop timeout to factory menu (applicable to Land Rover/Jaguar with Bosch head unit only)

This is a factory setting. Please change the time out to OFF in the menu.

Leave a Reply

Your email address will not be published. Required fields are marked *